Discussion:
SpamAssassin
(too old to reply)
Dan McAllister
2014-10-20 21:48:49 UTC
Permalink
Question:

Apparently I setup a system previously (some 3-4 years ago?) and didn't
install (or bypassed) spamassassin. How do I know? My sa-stats is EMPTY!

I recall the client specifically telling me to keep it off, but now he
wants it on -- and I cannot remember how I disabled it.

My simcontrol says
:clam=yes,spam=yes,spam_hits=12,attach=.mp3:.src:.bat:.pif

My /etc/mail/spamassassin folder contents look right... sa-check-spamd
has a response time of .425 seconds, so appears good.

Any ideas?

Thanks

Dan McAllister
IT4SOHO
--
IT4SOHO, LLC
33 - 4th Street N, Suite 211
St. Petersburg, FL 33701-3806

CALL TOLL FREE:
877-IT4SOHO

877-484-7646 Phone
727-647-7646 Local
727-490-4394 Fax

We have support plans for QMail!


---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-***@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-***@qmailtoaster.com
Eric Broch
2014-10-20 22:07:17 UTC
Permalink
Post by Dan McAllister
Apparently I setup a system previously (some 3-4 years ago?) and
didn't install (or bypassed) spamassassin. How do I know? My sa-stats
is EMPTY!
I recall the client specifically telling me to keep it off, but now he
wants it on -- and I cannot remember how I disabled it.
My simcontrol says
:clam=yes,spam=yes,spam_hits=12,attach=.mp3:.src:.bat:.pif
My /etc/mail/spamassassin folder contents look right... sa-check-spamd
has a response time of .425 seconds, so appears good.
Any ideas?
Thanks
Dan McAllister
IT4SOHO
Are you calling Simscan in tcp.smtp?


---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-***@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-***@qmailtoaster.com
Finn Buhelt
2014-10-20 22:40:45 UTC
Permalink
Hi Dan.

Are You looking for this ? initiated from cron (not usable in latest
Spamassassin due to new date format - logs now in maillog)

script: /usr/share/qmt/scripts/Spamdyke-Stats-Report.pl?

Regards,
Finn
Post by Dan McAllister
Apparently I setup a system previously (some 3-4 years ago?) and didn't
install (or bypassed) spamassassin. How do I know? My sa-stats is EMPTY!
I recall the client specifically telling me to keep it off, but now he
wants it on -- and I cannot remember how I disabled it.
My simcontrol says
:clam=yes,spam=yes,spam_hits=12,attach=.mp3:.src:.bat:.pif
My /etc/mail/spamassassin folder contents look right... sa-check-spamd
has a response time of .425 seconds, so appears good.
Any ideas?
Thanks
Dan McAllister
IT4SOHO
---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-***@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-***@qmailtoaster.com
Eric Broch
2014-10-20 23:20:35 UTC
Permalink
Post by Dan McAllister
Apparently I setup a system previously (some 3-4 years ago?) and
didn't install (or bypassed) spamassassin. How do I know? My sa-stats
is EMPTY!
I recall the client specifically telling me to keep it off, but now he
wants it on -- and I cannot remember how I disabled it.
My simcontrol says
:clam=yes,spam=yes,spam_hits=12,attach=.mp3:.src:.bat:.pif
My /etc/mail/spamassassin folder contents look right... sa-check-spamd
has a response time of .425 seconds, so appears good.
Any ideas?
Thanks
Dan McAllister
IT4SOHO
You can also tell if Spamassassin is working by looking at the header of
an email which will look like the following:

Received: by simscan 1.4.0 ppid: 27054, pid: 27056, t: 0.7393s
scanners: attach: 1.4.0 clamav: 0.98.4/m:55/d:19522 spam: 3.3.2
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
myhost.mydomain.com
X-Spam-Level: *
X-Spam-Status: No, score=1.3 required=5.0 tests=AWL,RDNS_NONE autolearn=no
version=3.3.2



---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-***@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-***@qmailtoaster.com
Dan McAllister
2014-10-21 12:31:20 UTC
Permalink
Post by Eric Broch
Post by Dan McAllister
Apparently I setup a system previously (some 3-4 years ago?) and
didn't install (or bypassed) spamassassin. How do I know? My sa-stats
is EMPTY!
I recall the client specifically telling me to keep it off, but now he
wants it on -- and I cannot remember how I disabled it.
My simcontrol says
:clam=yes,spam=yes,spam_hits=12,attach=.mp3:.src:.bat:.pif
My /etc/mail/spamassassin folder contents look right... sa-check-spamd
has a response time of .425 seconds, so appears good.
Any ideas?
Thanks
Dan McAllister
IT4SOHO
You can also tell if Spamassassin is working by looking at the header of
Received: by simscan 1.4.0 ppid: 27054, pid: 27056, t: 0.7393s
scanners: attach: 1.4.0 clamav: 0.98.4/m:55/d:19522 spam: 3.3.2
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
myhost.mydomain.com
X-Spam-Level: *
X-Spam-Status: No, score=1.3 required=5.0 tests=AWL,RDNS_NONE autolearn=no
version=3.3.2
---------------------------------------------------------------------
I'm getting into simscan, but apparently not spamassassin

Received: (qmail 9099 invoked by uid 89); 21 Oct 2014 12:28:57 -0000
Received: by simscan 1.4.0 ppid: 9090, pid: 9093, t: 0.1857s scanners:
attach: 1.4.0 clamav: 0.97.6/m:55/d:19522 spam: 3.3.2
Received: from unknown (HELO mail-yh0-f44.google.com) (209.85.213.44) by
cesfl.com with SMTP; 21 Oct 2014 12:28:57 -0000
Received-SPF: pass (cesfl.com: SPF record at _netblocks.google.com designates 209.85.213.44 as permitted sender)
Received: by mail-yh0-f44.google.com with SMTP id i57so1339354yha.3 for
<***@cesfl.com>; Tue, 21 Oct 2014 05:28:51 -0700 (PDT)

Dan
--
IT4SOHO, LLC
33 - 4th Street N, Suite 211
St. Petersburg, FL 33701-3806

CALL TOLL FREE:
877-IT4SOHO

877-484-7646 Phone
727-647-7646 Local
727-490-4394 Fax

We have support plans for QMail!


---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-***@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-***@qmailtoaster.com
Johannes Weberhofer
2014-10-21 14:04:35 UTC
Permalink
Post by Dan McAllister
attach: 1.4.0 clamav: 0.97.6/m:55/d:19522 spam: 3.3.2
This lines indicate that you mail has been scanned by simscan using clamav 0.97.6 and spamassassin 3.3.2
--
Johannes Weberhofer
Weberhofer GmbH, Austria, Vienna

---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-***@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-***@qmailtoaster.com
Dan McAllister
2014-10-21 21:57:37 UTC
Permalink
Post by Johannes Weberhofer
Post by Dan McAllister
attach: 1.4.0 clamav: 0.97.6/m:55/d:19522 spam: 3.3.2
This lines indicate that you mail has been scanned by simscan using
clamav 0.97.6 and spamassassin 3.3.2
Johannes:

Actually, the line indicates that the message is SCHEDULED to be scanned
-- the headers for the results of BOTH appear to be missing.

I may wind up un-installing and re-installing -- but this is a live
server with heavy use -- I'll have to redirect the traffic for a while
to do that.

Dan
--
IT4SOHO, LLC
33 - 4th Street N, Suite 211
St. Petersburg, FL 33701-3806

CALL TOLL FREE:
877-IT4SOHO

877-484-7646 Phone
727-647-7646 Local
727-490-4394 Fax

We have support plans for QMail!


---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-***@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-***@qmailtoaster.com
Eric Broch
2014-10-21 14:26:01 UTC
Permalink
Post by Dan McAllister
Post by Eric Broch
Post by Dan McAllister
Apparently I setup a system previously (some 3-4 years ago?) and
didn't install (or bypassed) spamassassin. How do I know? My sa-stats
is EMPTY!
I recall the client specifically telling me to keep it off, but now he
wants it on -- and I cannot remember how I disabled it.
My simcontrol says
:clam=yes,spam=yes,spam_hits=12,attach=.mp3:.src:.bat:.pif
My /etc/mail/spamassassin folder contents look right... sa-check-spamd
has a response time of .425 seconds, so appears good.
Any ideas?
Thanks
Dan McAllister
IT4SOHO
You can also tell if Spamassassin is working by looking at the header of
Received: by simscan 1.4.0 ppid: 27054, pid: 27056, t: 0.7393s
scanners: attach: 1.4.0 clamav: 0.98.4/m:55/d:19522 spam: 3.3.2
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
myhost.mydomain.com
X-Spam-Level: *
X-Spam-Status: No, score=1.3 required=5.0 tests=AWL,RDNS_NONE
autolearn=no
version=3.3.2
---------------------------------------------------------------------
I'm getting into simscan, but apparently not spamassassin
Received: (qmail 9099 invoked by uid 89); 21 Oct 2014 12:28:57 -0000
Received: by simscan 1.4.0 ppid: 9090, pid: 9093, t: 0.1857s
attach: 1.4.0 clamav: 0.97.6/m:55/d:19522 spam: 3.3.2
Received: from unknown (HELO mail-yh0-f44.google.com) (209.85.213.44) by
cesfl.com with SMTP; 21 Oct 2014 12:28:57 -0000
Received-SPF: pass (cesfl.com: SPF record at _netblocks.google.com
designates 209.85.213.44 as permitted sender)
Received: by mail-yh0-f44.google.com with SMTP id
i57so1339354yha.3 for
Dan
Dan,

Is there any logging info in '/var/log/qmail/spamd/current' and are the
permissions and owner set correctly on your spamassassin directory
(/etc/mail/spamassassin/.spamassassin)? The owner should be
vpopmail:vchkpw and permission drwxr-x-r-x.

Eric


---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-***@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-***@qmailtoaster.com
Loading...